Service Issue Reported – Intermittent slow or unresponsive browser
Incident Report for EBSCO Alert
Resolved
The issues customers reported with intermittent browser slowness and/or web pages not resolving when using EBSCOHost and EBSCO Discovery service are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 29, 2020 - 23:46 UTC
Investigating
EBSCO Customer Support has received reports of an issue with intermittent browser slowness and/or web pages not resolving when using EBSCOHost and EBSCO Discovery service. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 29, 2020 - 20:00 UTC
This incident affected: EBSCOhost Research Databases and EBSCO Discovery Service.