LibraryAware is currently unavailable
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Apr 27, 2024 - 01:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 27, 2024 - 00:11 UTC
Investigating
LibraryAware is currently unavailable. We are actively investigating the issue
Posted Apr 26, 2024 - 21:07 UTC
This incident affected: LibraryAware.