Service Issue Reported – ***EBSCO eBooks Leads to error***

Incident Report for EBSCO

Resolved

The issues customers reported with **eBooks** are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 08, 2026 - 16:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 08, 2026 - 16:31 UTC

Investigating

We have received reports of an issue with **eBooks***, specifically, **users receiving an error when attempting to access full text for some titles**. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 08, 2026 - 15:52 UTC
This incident affected: EBSCO eBooks.