Service Issue Reported – Multiple Products
Incident Report for EBSCO
Resolved
The issues customers reported with Multiple Products are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Sep 22, 2020 - 16:36 UTC
Update
We are continuing to investigate this issue.
Posted Sep 22, 2020 - 15:53 UTC
Update
We are continuing to investigate this issue.
Posted Sep 22, 2020 - 15:06 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Multiple Products showing slow response or timeouts. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Sep 22, 2020 - 14:58 UTC
This incident affected: EBSCOhost Research Databases, EBSCO Discovery Service, EBSCO Discovery Service API, EBSCO eBooks, Explora, Flipster, Full Text Finder Resolver, NoveList, and Stacks.