Service Issue Reported – Open URL Connection Issue - Item Not Found
Incident Report for EBSCO Alert
Resolved
The issues customers reported with Open URL Connection are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Aug 22, 2021 - 14:42 UTC
Investigating
EBSCO Customer Support has received reports of an issue with OpenURL Connection. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Aug 20, 2021 - 19:27 UTC
This incident affected: Additional Services.