Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 15, 2025 - 14:00 UTC
Scheduled
EBSCO will perform maintenance work on eBook Manager on Monday, December 15th starting at 9 AM ET (2 PM UTC) and it is expected to be completed in approximately four hours. During this maintenance window, the Export functionality in eBook Manager's My Collection feature will be disabled for all customers. The Export option will be automatically enabled for all customers once the maintenance work is complete.
Please note: This scheduled maintenance will have no impact to end user access to EBSCO eBooks or any other functionality in eBook Manager or other EBSCO products.
We apologize for any inconvenience this maintenance may cause.
Posted Dec 12, 2025 - 20:55 UTC
This scheduled maintenance affected: EBSCO eBooks and EBSCOhost Collection Manager.