Service Issue Reported – Delay in making some eBooks available on EBSCOhost/EBSCO Discovery Service if ordered
Incident Report for EBSCO
Resolved
The issues with eBook ordering are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Mar 15, 2024 - 13:16 UTC
Investigating
Due to an issue with the database production process for EBSCO eBooks, some newly ordered EBSCO eBook titles may not be available on EBSCOhost as quickly as expected. Affected eBooks are those that were new to the EBSCO eBooks catalog as of March 4th.

This issue could affect orders from March 4th - today.

Teams are actively working to resolve the issue and we will post a updates as progress is made.
Posted Mar 11, 2024 - 18:03 UTC
This incident affected: EBSCO eBooks.