Service Issue Reported –EBSCONET

Incident Report for EBSCO

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 15:17 UTC

Investigating

We have received reports of an issue with EBSCONET. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Jun 30, 2025 - 13:35 UTC
This incident affected: EBSCONET.