Service Issue Reported – EBSCOhost Collection Manager (ECM)
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCOhost Collection Manager log-in page being unavailable are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 13, 2019 - 19:44 UTC
Identified
EBSCO Customer Support has received reports of an issue with the EBSCOhost Collection Manager log-in page being unavailable. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 13, 2019 - 13:23 UTC
This incident affected: EBSCOhost Collection Manager.