Service Issue Reported – Holdings and Link Management
Incident Report for EBSCO
Resolved
The issue reported with Holdings Link Management UI is now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Dec 01, 2022 - 17:42 UTC
Investigating
We are experiencing some searching delays and results page viewing issues in Holdings and Link Management UI. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Dec 01, 2022 - 17:28 UTC
This incident affected: Holdings and Link Management.