Service Issue Reported – Multiple Services Impacted

Incident Report for EBSCO

Resolved

The issues customers reported with access to EBSCO platforms have been identified, and a fix implemented. We are monitoring for any further issues at this time. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 02, 2025 - 16:34 UTC

Investigating

We have received reports of issues with multiple EBSCO products. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 02, 2025 - 16:25 UTC
This incident affected: EBSCOhost Research Databases, EBSCO - New UI, and Holdings and Link Management.