Service Issue Reported – Holdings Management
Incident Report for EBSCO Alert
Resolved
The issues customers reported with Holdings Management are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Jun 23, 2020 - 11:54 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Holdings Management. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Jun 23, 2020 - 11:29 UTC
This incident affected: Additional Services.