Service Issue Reported – Dynamic Health
Incident Report for EBSCO
Resolved
The issues customers reported with Dynamic Health are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Jul 09, 2020 - 17:17 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Dynamic Health. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Jul 09, 2020 - 16:07 UTC
This incident affected: Additional Services.