Service Issue Reported – ***STACKS***

Incident Report for EBSCO

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 20:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 15:36 UTC

Investigating

We have received reports of an issue with **STACKS**, specifically intermittent issues with STACKS timing out or resolving in a 504 error. Our engineering teams are currently investigating the issue, and we will update this page when more information is available.
Posted Sep 03, 2026 - 15:15 UTC
This incident affected: Stacks.