Service Issue Reported – eBook errors
Incident Report for EBSCO Alert
Resolved
The issues customers reported with eBooks are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Apr 04, 2020 - 13:23 UTC
Investigating
EBSCO Customer Support has received reports of an issue with eBooks. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Apr 03, 2020 - 18:39 UTC
This incident affected: EBSCO eBooks.