Service Issue Reported – DynaMed and Dynamic Health
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted Aug 24, 2019 - 14:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 24, 2019 - 14:08 UTC
Investigating
EBSCO Customer Support has received reports of an personal authentication issue with DynaMed and Dynamic Health. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Aug 24, 2019 - 13:49 UTC
This incident affected: DynaMed and Additional Services.