Service Issue Reported – Multiple Resource Loading Issue
Incident Report for EBSCO Alert
Resolved
The issues customers reported with multiple EBSCO resources are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Sep 16, 2020 - 16:17 UTC
Update
We are continuing to investigate this issue.
Posted Sep 16, 2020 - 15:24 UTC
Update
We are continuing to investigate this issue.
Posted Sep 16, 2020 - 15:20 UTC
Update
We are continuing to investigate this issue.
Posted Sep 16, 2020 - 14:33 UTC
Investigating
EBSCO Customer Support has received reports of an intermittent loading issue with EBSCO Discovery Service. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Sep 16, 2020 - 14:25 UTC
This incident affected: EBSCOhost Research Databases, EBSCO Discovery Service, and Flipster.