Service Issue Reported – EBSCOadmin
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCOadmin are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Sep 16, 2019 - 20:00 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCOadmin. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Sep 16, 2019 - 17:54 UTC
This incident affected: EBSCOadmin.