Service Issue Reported – New EBSCOHost/New EBSCO Discovery Service Upstream Error
Incident Report for EBSCO
Resolved
The issues customers reported with new EBSCOhost and new EBSCO Discovery Service interfaces are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Nov 19, 2024 - 17:34 UTC
Investigating
We have received reports of an issue with the new EBSCOhost and new EBSCO Discovery Service interfaces. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Nov 19, 2024 - 16:24 UTC
This incident affected: EBSCO - New UI.