EBSCOadmin: Reports & Statistics Access Issue
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCOadmin: Reports & Statistics are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Aug 19, 2019 - 18:19 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCOadmin: Reports & Statistics. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Aug 19, 2019 - 07:50 UTC
This incident affected: EBSCOadmin.