Service Issue Reported – emails sent to EBSCO Support
Incident Report for EBSCO Alert
Resolved
The issues customers reported with emails sent to EBSCO Technical Support are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Jul 30, 2020 - 14:10 UTC
Investigating
EBSCO Customer Support has received reports of an issue with emails sent to EBSCO Technical Support. Our engineering teams are currently investigating the issue and we will update this page when more information is available. In the meantime, please submit Support cases using our online case form on EBSCO Connect: https://connect.ebsco.com/s/contactsupport?language=en_US .
Posted Jul 30, 2020 - 02:12 UTC
This incident affected: Additional Services.