Service Issue Reported – Holdings Management
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 21:24 UTC
Update
We are continuing to investigate this issue.
Posted Feb 20, 2020 - 19:24 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Holdings Management. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Feb 20, 2020 - 19:23 UTC
This incident affected: Full Text Finder Resolver.