Invoices currently unavailable in GOBI - Monday Oct 12
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 12:17 UTC
Investigating
Good Morning,
Our 3rd party invoicing partner is currently experiencing a system-wide issue which is preventing invoices from displaying in GOBI. Our partner is actively investigating the outage and is working to resolve it. Updates will be provided as they become available.
Thank you for your patience.
Posted Oct 12, 2020 - 14:18 UTC
This incident affected: GOBI.