Service Issue Reported – Adobe DRM Full eBook Downloads Error

Incident Report for EBSCO

Resolved

The issues customers reported with eBook downloads, specifically, downloading full, Adobe-DRM-protected EBSCO eBooks are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Apr 09, 2026 - 12:34 UTC

Investigating

We have received reports of an issue with eBook downloads, specifically, downloading full, Adobe-DRM-protected EBSCO eBooks. This issue is due to Adobe-driven 3rd party maintenance. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Apr 08, 2026 - 13:12 UTC
This incident affected: EBSCO eBooks.