Service Issue Reported – Usage Report
Incident Report for EBSCO
Resolved
The issues customers reported with Industry Standard (Counter5) Usage Reporting, Publisher Usage Reporting, Standard Product Usage Reporting, Holding Management Reporting are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Jul 29, 2022 - 07:25 UTC
Investigating
We have received reports of an issue with Industry Standard (Counter5) Usage Reporting, Publisher Usage Reporting, Standard Product Usage Reporting, Holding Management Reporting. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Jul 29, 2022 - 03:56 UTC
This incident affected: EBSCOadmin.