Service Issue Reported – Auto Repair Source
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted Aug 30, 2019 - 23:19 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Auto Repair Source. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Aug 30, 2019 - 22:02 UTC
This incident affected: Additional Services.