Service Issue Reported – EBSCOhost Collection Manager
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCOhost Collection Manager are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Oct 07, 2020 - 01:09 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCOhost Collection Manager. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Oct 07, 2020 - 00:35 UTC
This incident affected: EBSCOhost Collection Manager.