Service Issue Reported – Publication Finder
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 19:10 UTC
Update
We are continuing to investigate this issue.
Posted Mar 21, 2023 - 18:29 UTC
Update
We are continuing to investigate this issue.
Posted Mar 21, 2023 - 15:27 UTC
Investigating
We have received reports of an issue with Publication Finder when accessing via specific URLs. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Mar 21, 2023 - 15:20 UTC
This incident affected: Publication Finder.