Service Issue Reported – Additional Services
Incident Report for EBSCO Alert
Resolved
The issues customers reported with Additional Services - PING SSO are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Apr 28, 2021 - 19:04 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Additional Services. Our engineering teams are currently investigating the issue and we will update this page when more information is available.

Ping SSO users are encountering an error when attempting to access EBSCO. This is occurring via the Guest Access banner and through URLs with the SSO authtype.
Posted Apr 28, 2021 - 17:22 UTC
This incident affected: Additional Services.