Service Issue Reported – EBSCO Connect
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCO Connect are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Apr 17, 2019 - 17:50 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCO Connect. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Apr 17, 2019 - 15:17 UTC
This incident affected: EBSCO Connect.