Service Issue Reported – **EBSCOhost/EDS/Explora**
Incident Report for EBSCO Alert
Resolved
The issues customers reported with slowness or lack of access are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted 26 days ago. Jan 25, 2019 - 18:02 UTC
Investigating
EBSCO Customer Support has received reports of customers experiencing slowness or lack of access to their EBSCO products. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted 26 days ago. Jan 25, 2019 - 16:39 UTC
This incident affected: EBSCOhost Research Databases, EBSCO Discovery Service, Full Text Finder, EBSCO Discovery Service API, and Explora.