Service Issue Reported – Consumer Reports Access Issue
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2019 - 13:48 UTC
Investigating
EBSCO Customer Support has received reports of an access issue with Consumer Reports. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted about 1 month ago. Jul 16, 2019 - 18:28 UTC
This incident affected: Additional Services.