Usage Consolidation and Holdings Management - System Maintenance
Incident Report for EBSCO Alert
Resolved
Scheduled maintenance of Holdings Management and Usage Consolidation has been completed at this time. Thank you for your patience.
Posted Jun 02, 2020 - 15:08 UTC
Monitoring
EBSCO is performing scheduled maintenance on Monday, June 1st until Tuesday June 2nd at 4am EST (8am UCT). Customers may experience interruptions or slowness with Holdings Management, and Usage Consolidation will be unavailable during this time. We apologize for any inconvenience this temporary interruption may cause.
Posted Jun 02, 2020 - 02:27 UTC
This incident affected: EBSCOadmin and Additional Services.