Service Issue Reported – eBooks/Australia/New Zealand Reference Centre Plus Access issues
Incident Report for EBSCO Alert
Resolved
The issues customers reported with access to EBSCO eBooks and Australia/New Zealand Reference Centre Plus, are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted about 2 months ago. Jun 27, 2019 - 10:57 UTC
Investigating
EBSCO Customer Support has received reports of an issue with EBSCO eBooks and Australia/New Zealand Reference Centre Plus. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted about 2 months ago. Jun 27, 2019 - 09:30 UTC
This incident affected: EBSCOhost Research Databases and EBSCO eBooks.