GOBI Currently Unavailable - September 14th, 2020
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Sep 15, 2020 - 12:00 UTC
Investigating
We have become aware of an issue which is preventing users from logging into GOBI. We are actively working to resolve the issue and will post updates as information becomes available.
Posted Sep 14, 2020 - 19:25 UTC
This incident affected: GOBI.