Service Issue Reported – Holdings Management
Incident Report for EBSCO Alert
Resolved
The issues customers reported with Holdings Management are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted 3 months ago. May 30, 2019 - 19:00 UTC
Investigating
EBSCO Customer Support has received reports of an issue accessing Holdings Management within EBSCOadmin. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted 3 months ago. May 30, 2019 - 18:50 UTC
This incident affected: EBSCOadmin.