Service Issue Reported – ECM - EBSCOhost Collection Manager- Unable to log in
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCOhost Collection Manager are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted 4 months ago. Dec 04, 2018 - 16:37 UTC
Investigating
EBSCO Customer Support has received reports of an issue with logging in to EBSCOhost Collection Manager. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted 4 months ago. Dec 04, 2018 - 14:49 UTC
This incident affected: EBSCOhost Collection Manager.