Service Issue reported - Full Text Finder error
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 14:14 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Full Text Finder links returning errors. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Feb 18, 2021 - 11:57 UTC
This incident affected: Full Text Finder Resolver.