Service Issue Reported – eBook Services
Incident Report for EBSCO
Resolved
The issues customers reported with eBook Services are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Apr 14, 2021 - 14:38 UTC
Investigating
EBSCO Customer Support has received reports of an issue with eBook Services, including online viewing and downloads. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Apr 14, 2021 - 14:27 UTC
This incident affected: EBSCO eBooks.