Service Issue Reported – EBSCOhost and EDS
Incident Report for EBSCO Alert
Resolved
The issues customers reported with latency when accessing EBSCOhost and EDS are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted 3 months ago. May 29, 2019 - 21:01 UTC
Identified
EBSCO Customer Support has identified an issue with latency when accessing EBSCOhost and EDS. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted 3 months ago. May 29, 2019 - 17:35 UTC
This incident affected: EBSCOhost Research Databases and EBSCO Discovery Service.