Service Issues Reported – Full Text Finder and Dynamed Plus
Incident Report for EBSCO Alert
Resolved
This incident has been resolved.
Posted about 2 months ago. Dec 20, 2018 - 12:42 UTC
Investigating
EBSCO Customer Support has received reports of an issue with Full Text Finder and Dynamed Plus. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted about 2 months ago. Dec 20, 2018 - 10:49 UTC
This incident affected: Full Text Finder and DynaMed Plus.