Service Issue Reported – **Unable to log into EBSCONet**
Incident Report for EBSCO Alert
Resolved
The issues customers reported with EBSCONet are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted about 2 months ago. Nov 29, 2018 - 19:32 UTC
Update
We are continuing to investigate this issue.
Posted about 2 months ago. Nov 29, 2018 - 19:31 UTC
Investigating
EBSCO Customer Support has received reports of an issue with **EBSCONet**. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted about 2 months ago. Nov 29, 2018 - 19:04 UTC
This incident affected: Additional Services.