Service Issue Reported – Slow or unresponsive EBSCO services
Incident Report for EBSCO Alert
Resolved
The issues customers reported with slow or unresponsive service are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Oct 08, 2020 - 13:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2020 - 13:44 UTC
Identified
EBSCO Customer Support has received reports of an issue accessing EBSCO services. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Oct 08, 2020 - 13:40 UTC
This incident affected: GOBI, EBSCOhost Research Databases, EBSCO Discovery Service, Full Text Finder, EBSCO Discovery Service API, Flipster, EBSCO eBooks, EBSCOadmin, EBSCOhost Collection Manager, DynaMed, Explora, NoveList, Additional Services, EBSCO Connect, EBSCONET, Dynamed & Micromedex, and Stacks.