Service Issue Reported – Flipster
Incident Report for EBSCO Alert
Resolved
The issues customers reported with Flipster are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Sep 13, 2019 - 17:40 UTC
Investigating
EBSCO Customer Support has received reports of an issue with the "Find My Library" function on the Flipster Mobile App. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Sep 13, 2019 - 14:53 UTC
This incident affected: Flipster.