Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2025 - 07:30 UTC
Update
Updated: On Thursday, November 20th, beginning at 2:30 AM ET (7:30 AM UTC), EBSCO will perform scheduled maintenance on EBSCO Experience Manager (EEM) and EBSCO's Implementation Tool for OpenAthens Customers. Both EEM and EBSCO's implementation tool will be available during this time, however users may intermittently receive errors and be logged out. They will need to reauthenticate. This maintenance is expected to last one hour.
Please note this scheduled maintenance does not affect OpenAthens authentication into EBSCO products.
We apologize for any inconvenience this poses.
Posted Nov 13, 2025 - 13:51 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 13, 2025 - 13:48 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 13, 2025 - 02:45 UTC
Scheduled
Updated: On Thursday, November 20th, beginning at 2:30 AM ET (7:30 AM UTC), EBSCO will perform scheduled maintenance on EBSCO Experience Manager (EEM) and EBSCO's Implementation Tool for OpenAthens Customers. Both EEM and EBSCO's implementation tool will be available during this time, however users may intermittently receive errors and be logged out. They will need to reauthenticate. This maintenance is expected to last one hour.
Please note this scheduled maintenance does not affect OpenAthens authentication into EBSCO products.
We apologize for any inconvenience this poses.
Posted Nov 12, 2025 - 16:47 UTC
This scheduled maintenance affected: EBSCO Experience Manager and Additional Services.