Service Issue Reported – New EDS UI/Mobile/PFUI/Dynamed
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCO products are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 12, 2022 - 21:57 UTC
Monitoring
The issues customers reported with multiple EBSCO products have been identified and a solution has been deployed. Our engineering teams are monitoring the solution at this time. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 12, 2022 - 21:44 UTC
Update
We have received reports of an issue with customers experiencing errors attempting to access some EBSCO products. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 12, 2022 - 20:54 UTC
Investigating
We have received reports of an issue with customers experiencing errors attempting to access some EBSCO products. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 12, 2022 - 20:47 UTC
This incident affected: DynaMed Decisions, DynaMed, DynaMedex, Dynamic Health, EBSCO Discovery Service - New UI, EBSCO Mobile App, and Publication Finder.