Service Issue Reported – EBSCO Discovery Service and EBSCOhost
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCO Discovery Service and EBSCOhost are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted May 07, 2020 - 23:48 UTC
Update
We are continuing to investigate this issue.
Posted May 07, 2020 - 22:00 UTC
Update
We are continuing to investigate this issue.
Posted May 07, 2020 - 21:57 UTC
Update
We are continuing to investigate this issue.
Posted May 07, 2020 - 21:39 UTC
Investigating
EBSCO Customer Support continues to receive reports of an issue with all EBSCO services. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted May 07, 2020 - 17:50 UTC
This incident affected: DynaMed, EBSCOadmin, EBSCOhost Research Databases, EBSCO Discovery Service, EBSCO Discovery Service API, EBSCO eBooks, EBSCOhost Collection Manager, Explora, Flipster, Full Text Finder Resolver, GOBI, NoveList, and Additional Services.