Service Issue Reported – Intermittent Issue Loading EDS and EBSCOhost
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCOhost and EBSCO Discovery Service are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Mar 21, 2019 - 04:02 UTC
Investigating
EBSCO Customer Support has received reports of an issue with loading EDS and EBSCOhost. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Mar 20, 2019 - 20:22 UTC
This incident affected: EBSCOhost Research Databases and EBSCO Discovery Service.