Service Issue Reported – EBSCONET
Incident Report for EBSCO
Resolved
The issues customers reported with EBSCONet are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Aug 21, 2020 - 20:18 UTC
Monitoring
We are glad to report that EBSCONET is now available. We apologize for the inconvenience, and we appreciate your patience. Orders, renewals, title catalog, and the Customer Service Portal are available and most reporting is available. We are finalizing updates to the Financial Information tab and to a few reports, and users who access these through EBSCONET may temporarily not have access to these documents. We expect this to be resolved shortly.
Posted Aug 18, 2020 - 00:47 UTC
Update
Orders, renewals, title catalog, the Customer Service Portal are available and most reporting is available. We are finalizing updates to the Financial Information tab and to a few reports, and users who access these through EBSCONET may temporarily not have access to these documents. We expect this to be resolved shortly.

For any specific needs or questions, please contact your customer representative.
Posted Aug 18, 2020 - 00:39 UTC
Update
EBSCONET remains unavailable at this time. However, we understand the cause of the outage and have been working around the clock to restore service. We expect EBSCONET to be available within the next 24 hours. We apologize for the inconvenience, and will post a message when service is live.
Posted Aug 17, 2020 - 18:01 UTC
Update
Our engineering teams continue to work on this issue. We will update this page when more information is available. Thank you for your continued patience.
Posted Aug 15, 2020 - 17:05 UTC
Update
Our engineering teams continue to work on this issue. We will update this page when more information is available. Thank you for your continued patience.
Posted Aug 14, 2020 - 14:36 UTC
Update
Our engineering teams continue to work on this issue. We will update this page when more information is available. Thank you for your continued patience.
Posted Aug 13, 2020 - 23:59 UTC
Update
Our engineering teams are continuing to work on resolving this issue and we will update this page when more information is available. Thank you for your patience.
Posted Aug 11, 2020 - 13:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 10, 2020 - 15:13 UTC
Update
We are continuing to investigate this issue.
Posted Aug 10, 2020 - 11:08 UTC
Update
We are continuing to investigate this issue.
Posted Aug 10, 2020 - 11:07 UTC
Investigating
We have an operational outage which is impacting EBSCONET. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Aug 10, 2020 - 11:07 UTC
This incident affected: EBSCONET.