Service Issue Reported – Auto Repair Source
Incident Report for EBSCO Alert
Resolved
The outage which was previously impacting Auto Repair Source is now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.
Posted Jun 26, 2019 - 13:28 UTC
Investigating
EBSCO Customer Support is currently aware of an outage impacting Auto Repair Source. Our engineering teams are currently investigating the issue and we will update this page when service is restored.
Posted Jun 26, 2019 - 12:34 UTC
This incident affected: Additional Services.